The information in this manual may be altered without notice.

BRUKER accepts no responsibility for actions taken as a result of use of this manual. BRUKER accepts no liability for any mistakes contained in the manual, leading to coincidental damage, whether during installation or operation of the instrument. Unauthorised reproduction of manual contents, without written permission from the publishers, or translation into an other language, either the entire manual or a part of it, is forbidden.

This manual describes the units as they are at the date of printing. On request, the manufacturer shall supply circuit diagrams, lists of components, descriptions, calibrating instructions and any other information for use by qualified personnel of the user, in charge of repairing the parts of the unit which have been stated by the manufacturer to be "repairable". Such supply shall in no event constitute permission to modify or repair the units or approval of the same.

All rights reserved for the units, circuits, processes and appellations mentioned herein.

This unit is not designed for any type of use which is not specifically described in this manual. Such use may be hazardous.

This manual was written by

BROSSEAU Vincent

© November 17, 2006: Bruker Biospin SA

Wissembourg, France

P/N: Z31807
DWG-Nr: Z4D10197
Contents

1 Preemphasis tool for the gradient amplifiers ..... 5
1.1 What is SetPre used for? .................................................... 5
1.2 Starting SetPre ................................................................. 6
1.3 Command options ........................................................... 7

2 The Graphical User Interface .................. ............ ........ 9
2.1 The common controls ........................................................ 9
   Device identification .................................................... 9
   Channel control .......................................................... 9
   Preemphasis sliders ..................................................... 10
   Read/Write parameters files .......................................... 12
   The Toolbar ................................................................. 12
   GradPar and RampPar tools ............................................. 13
   Amplifier and Preemphasis activation ............................. 13
   Reset protection ........................................................... 14
2.2 The amplifier-dependant controls ........................................ 14
   Offset (all amplifiers except BGU2) ............................... 14
   Loop parameters (all amplifiers except BGU2) ............... 14
   Amplifier gain (Master Unit only) ................................. 15
   Rate temperature (all amplifiers except GREATs) .......... 15
   Other controls (from the "Options" menu) ....................... 15

Figures ................................................................. 17
What is SetPre used for?

For electronic reasons, the gradient signal generated by the GCU/GCON is never exactly as expected (see Figure 1.1).

**Figure 1.1. GCU/GCON signal**

![Expected and Measured Signals](image)

That's why it's necessary to create another signal which can be added with the GCU/GCON signal, in order to correct the distortion. This additional signal is the preemphasis signal (see Figure 1.2).

**Figure 1.2. Preemphasis correction**

![Preemphasis](image)

The SetPre program is the tool that must be used to set this preemphasis signal (the red curve on Figure 1.2).
Preemphasis tool for the gradient amplifiers

Starting SetPre

To start SetPre, type "setpre" in the TOPSPIN command line. The GUI communicates with a server-program which controls the hardware (the gradient amplifier) and handles the parameters files. If the GUI does not manage to connect to this server (for example because of network troubles), the message shown on Figure 1.3 may be displayed.

Figure 1.3. Server connection error

If the server connection succeeds, then the server gets the current hardware configuration. If a suitable device is detected (a GAB, or a Master Unit, or any preemphasis amplifier), its associated graphical user interface is displayed (see "The Graphical User Interface" on page 9). In the other case, one of the messages shown on Figure 1.4 may be displayed.

Figure 1.4. Amplifier detection error
You may start SetPre with the following options (the keyword must be preceded by the "-") character):

- **-ii**

  This option forces the hardware detection (recommended if the connected amplifier has been changed).

- **-debug**

  In any case, while SetPre is running, it writes some "log" messages in a logfile, "setpre.log" (in `<TOPSPINHOME>/prog/logfiles`), like error messages and other main events.

  The "debug" option simply makes SetPre more "talkative": it will write more information in the logfile.

- **-probe**

  This informs SetPre that it must read the "default" parameters file associated to the current probehead (identified by its PROBEID), and then upload the parameters to the hardware. *No GUI is started.*

All the parameters files are stored on the disk in the directory:

`<TOPSPINHOME>/exp/stan/nmr/parx/preemp/<PROBEID>`
Preemphasis tool for the gradient amplifiers
The Graphical User Interface

2.1 The common controls

2.1.1 Device identification

On the upper left corner of the window, you can see which device is connected. The possible names are:

- AVANCE amplifiers: "GAB", "BGU2", "GREAT 1/10", "GREAT 3/10" or "Master Unit".
- IPSO amplifiers: "GREAT 3/10-E"

On the lower right corner of the window, the current probehead ID is indicated (you must define/create it with the command [edhead] before using setpre).

Note: the GAB has no GUI, but the SetPre menu ("File" and "Edit") is available.

2.1.2 Channel control

The default selected channel is always Z (if it's available). But you can select any other channel in the pull-down list at the top of the window.

The content of this list depends on the current hardware configuration (see the example of the Master Unit, on Figure 2.1).
The Graphical User Interface

Figure 2.1. Channel control

<table>
<thead>
<tr>
<th>Device</th>
<th>Available channels</th>
</tr>
</thead>
<tbody>
<tr>
<td>GAB</td>
<td>none</td>
</tr>
<tr>
<td>BGU2</td>
<td>X,Y,Z,XB0,YB0,SB0,YX,XY,XZ,ZX,ZY,YZ</td>
</tr>
<tr>
<td>GREAT 1/10</td>
<td>Z</td>
</tr>
<tr>
<td>GREAT 3/10</td>
<td>X,Y,Z</td>
</tr>
<tr>
<td>Master Unit</td>
<td>X,Y,Z,XB0,YB0,SB0 (*)</td>
</tr>
<tr>
<td>GREAT 3/10-E</td>
<td>X,Y,Z,YX,XY,XZ,ZX,ZY,YZ</td>
</tr>
</tbody>
</table>

(*) Master Unit constraints:
- X, Y and Z are available only if amplifier X, Y and Z resp. are connected
- XB0 available only if amplifier X and amplifier B0 are connected
- YB0 available only if amplifier Y and amplifier B0 are connected
- ZB0 available only if amplifier Z and amplifier B0 are connected

Preemphasis sliders 2.1.3

AVANCE amplifiers (BGU2, GREATs, Master Unit)
Preemphasis are generated by the amplifier controller itself.
The preemphasis signal results from the addition of 3 preemphasis curves (see Figure 2.2).
The common controls

Figure 2.2. Preemphasis signal

Each curve is an exponential function defined by its gain and its time constant (see Figure 2.3).

Figure 2.3. Preemphasis control

Time base: "DC", "0.2 ms", "2.0 ms", "20 ms", "200 ms", "2 s", or "20 s"

Time: its lower limit is 0 ms, and its upper limit value depends of the selected time base (ex.: if time base is "200 ms", then time max. is 200 ms).

Gain: from -100% to 100%

IPS0 amplifiers (GREAT 3/10-E)

Preemphasis are generated by the DPP board, plugged in the IPS0 computer.

The preemphasis signal results from the addition of 6 preemphasis curves.

Time base: "0.2 ms", "2.0 ms", "20 ms", "200 ms", "2 s", or "20 s"

Time: its lower limit is 0 ms, and its upper limit value depends of the selected time base (ex.: if time base is "200 ms", then time max. is 200 ms).

Gain: from -10% to 10%
In the SetPre "File" menu, you may choose to read or write a parameter file (see Figure 2.4). You may select the file in a dialog box ("Read from…" or "Write to…"), or you may use the "default".

In any case, all the parameters file localisation depends on the current probe-head.

They are stored in `<TOPSPINHOME>/exp/stan/nmr/parx/preemp/<PROBEID>`. 

![Figure 2.4. File menu](image)

**The Toolbar 2.1.5**

Parameters

For convenient reason, some parameters may be handled in memory.

- **store** the current parameters in memory (NOT on the disk):
  - Preemphasis
  - Impedance (GREATs and Master Unit only)
  - offset and loop parameters (GREATs only)
  - amplifier gain (Master Unit only)

- **recall** the stored parameters

- **exchange** the current parameters with those which are stored

- **undo** the modifications (set the initial values)

- **clear** the preemphasis gain values
Common

help : open this user's guide
about : open the "about" window (author information)

GradPar and RampPar tools

From the "Edit" menu (see Figure 2.5), you can start the other tools "GradPar" (the gradient parameters GUI) and RampPar (the ramp parameters GUI).

Figure 2.5. Edit menu

Gradient parameters and ramp parameters are stored where the other parameters (offsets, loop parameters, preemphasis, …etc) are stored, but the gradient parameters are also stored in the file <TOPSPINHOME>/conf/instr/gradient_calib.

Amplifier and Preemphasis activation

From the "Options" menu (see Figure 2.6), you can activate/deactivate each amplifier and each preemphasis correction.

Figure 2.6. Options menu

AVANCE amplifiers (BGU2, GREATs, Master Unit)

- amplifier activation : only for channels X, Y and Z
- preemphasis activation : only for channels X, Y and Z
The Graphical User Interface

**IPSO amplifiers (GREAT 3/10-E)**
- amplifier activation: only for channels X, Y and Z
- preemphasis activation: for all channels (depending on the connected device)

**Reset protection**

From the "Options" menu (see Figure 2.6), you can reset the amplifier protection.

**The amplifier-dependant controls**

**Offset (all amplifiers except BGU2)**

The preemphasis offset may be adjusted (from -100% to 100%) thanks to the specific slider control (see Figure 2.7).

![Figure 2.7. Offset adjustment](image)

The "Auto" option may be activated to start the offset auto-adjustment. In this case, when the auto-adjustment is finished, the offset value is updated and the slider is adjusted too.

Those features are channel-dependant (each channel - X, Y and Z - has its own offset). It's possible to start the offset auto-adjustment of all the channels simultaneously, thanks to the menu item "Offset adjustment" in the "Options" menu (see Figure 2.6).

**Loop parameters (all amplifiers except BGU2)**

You can access to the loop parameters from the item menu "Loop parameters", in the "Options" menu (see Figure 2.6). The NMR administration password is required (see Figure 2.8).

![Figure 2.8. NMR administration password](image)
The amplifier-dependant controls

If the access is granted, specific sliders will be displayed. Use them to change the impedance value ("Low" or "High") and the capacitors and resistors values (from 0% to 100%, see Figure 2.9).

Figure 2.9. Loop parameters

<table>
<thead>
<tr>
<th>Impedance</th>
<th>Resistors [%]</th>
<th>Capacitors [%]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Low</td>
<td>33.3</td>
<td>40.7</td>
</tr>
<tr>
<td>High</td>
<td>0.1</td>
<td>0.1</td>
</tr>
</tbody>
</table>

Amplifier gain (Master Unit only) 2.2.3

As you can see on Figure 2.10, you can select from 10A to 40A (or 60A, depending on which type of amplifier is connected).

Figure 2.10. Amplifier gain

Rate temperature (all amplifiers except GREATs) 2.2.4

The device internal temperature is displayed on the upper right corner of the SetPre window. Its value is refreshed every X seconds, where X may be set from the "Rate to measure temperature" item in the "Options" menu (see Figure 2.11).

Figure 2.11. Rate temperature

Other controls (from the "Options" menu) 2.2.5

- B0 compensation (BGU2 and Master Unit only)
- Gradient generation (BGU2 only)
- Blanking inhibited (IPSO amplifiers only)
The Graphical User Interface
Figures

1 Preemphasis tool for the gradient amplifiers 5
Figure 1.1. GCU/GCON signal ........................................................... 5
Figure 1.2. Preemphasis correction .................................................. 5
Figure 1.3. Server connection error .................................................. 6
Figure 1.4. Amplifier detection error .................................................. 6

2 The Graphical User Interface 9
Figure 2.1. Channel control .............................................................. 10
Figure 2.2. Preemphasis signal ......................................................... 11
Figure 2.3. Preemphasis control ....................................................... 11
Figure 2.4. File menu ...................................................................... 12
Figure 2.5. Edit menu ..................................................................... 13
Figure 2.6. Options menu ............................................................... 13
Figure 2.7. Offset adjustment .......................................................... 14
Figure 2.8. NMR administration password ....................................... 14
Figure 2.9. Loop parameters ........................................................... 15
Figure 2.10. Amplifier gain ............................................................ 15
Figure 2.11. Rate temperature ........................................................ 15
Figures